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ROZDZIAŁ I - iMaper 

1 Podstawowe zadania aplikacji oraz wymagania 
systemowe 

1.1 Moduły aplikacji 

 iMaper - główny moduł aplikacji. 

 Topol - moduł do kontroli i poprawy topologii. 

 Taged - moduł do edycji atrybutów (tagów). 

 Shpdgn - moduł do importu i exportu plików shp. 

1.2 Podstawowe zadania aplikacji 

 Tworzenie obiektowej mapy z zakresu EGiB, GESUT, BDOT500 

 Konwersja i obróbka danych w formatach DGN, DXF/DWG, SHP i inne. 

 Export/Import danych w formatach Geoinfo, Ewid, Ewmapa, SHP. 

 Realizacja obliczeń geodezyjnych. 

 Integracja części graficznej EGiB z częścią opisową. 

 Transformacje obiektów oraz rastrów pomiędzy układami współrzędnych. 

 Kontrola i automatyczna poprawa topologii obiektów. 

 Generowanie raportów i wyrysów geodezyjnych. 

1.3 Wymagania systemowe oraz instalacja aplikacji 

Aplikacja jest kompatybilna z: MicroStation, PowerDraft w wersjach V8, XM, V8i. 

Instalacja:  

Aplikacja składa się z biblioteki [iMaper] oraz modułów aplikacji: imaper.ma, 
topol.ma, taged.ma. 

Bibliotekę [iMaper] należy przekopiować do przestrzeni roboczej MicroStation 
(Workspace). W zależności od systemu operacyjnego oraz wersji MicroStation 
przestrzeń ta znajduje się w różnych miejscach. Przykładowa lokalizacja dla 
Windows 7 oraz MicroStation XM:  

c:\ProgramData\Bentley\WorkSpace\Projects\ 

c:\ProgramData\Bentley\WorkSpace\Users\ 

odpowiednie katalogi z biblioteki [iMaper] należy przegrać do ww. lokalizacji. 

Moduły aplikacji (.ma) należy przegrać do katalogu [mdlapps], przykładowo: 

c:\Program Files (x86)\Bentley\MicroStation\mdlapps\ 

 

Uruchomienie: 

Po uruchomieniu Microstation należy wybrać odpowiednie środowisko: 
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2 Rozwarstwienie i definicja obiektów. 
Wraz z aplikacją dostarczany jest rysunek prototypowy imaper_seed.dgn 
zawierający standardowe warstwy i zestawy atrybutów z zakresu EGiB, GESUT, 
BDOT500. 

Ważne warstwy używane przez aplikację: 

 ERROR - warstwa do sygnalizacji błędów 

 UWAGA - warstwa do sygnalizacji uwag 

 TEMP - warstwa dla obiektów wykorzystanych 

Ważne atrybuty używane przez aplikację: 

 ityp - atrybut pomocniczy 

 idgiv - identyfikator obiektu Geoinfo 

Istnieje również możliwość zakładania dowolnych warstw i atrybutów. 

UWAGA! 

Podstawowym założeniem aplikacji jest zgodność nazwy warstwy z nazwą zestawu 
atrybutów (tagów). Przykładowo dla działki ewidencyjnej: 

 warstwa = DZE 

 zestaw atrybutów = dze 

Kolejnym wymaganiem (wynikającym z różnych wersji Microstation) jest 
definiowanie nazwy warstwy dużymi literami, a nazwy zestawu atrybutów i atrybuty 
małymi. Zaleca się również nie używanie polskich liter. 

 

Prezentacja graficzna obiektów z zakresu EGiB definiowane jest z poziomu 
aplikacji: [iMaper] -> [Ustawienia]. 

3 Pozyskiwanie danych 

3.1 Tworzenie obiektów powierzchniowych na podstawie elementów 
CAD 

Tworzenie obiektów powierzchniowych na podstawie widocznych elementów 
typu: text, line, linestring, shape (shape – w przypadku ustawienia Użyj shapy do 
obiektowania). Menu [Tools]->[Obiektowanie]. 
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Aplikacja szuka obszarów zamkniętych wraz z enklawami na podstawie tekstu 
(centroid) oraz obiektów liniowych. Przed obiektowaniem warto sprawdzić 
topologię linii w celu wyeliminowania niedociągnięć – patrz rozdział Kontrola 
topologii. W trakcie obiektowania przypisywane są atrybuty zgodnie z zapisem w 
polu Tagi. Do wyboru są standardowe obiekty ewidencyjne (działka, klasoużytek, 
budynek itp.) oraz dowolny obiekt - Obiekt-Lvl. W tym przypadku tworzony jest 
obiekt na warstwie zgodnej ze wskazanym tekstem i atrybutami takimi jak w polu 
Tagi. 

Przykład: 

 tekst (centroid) na warstwie TEST: 10;Leśna 

 pole Tagi: nr;ulica 

Utworzony zostanie obiekt powierzchniowy na warstwie TEST z zestawem 
atrybutów test oraz atrybutami: nr=10 i ulica=Leśna. 

 

Możliwe jest obiektowanie  

 pojedynczo: z głównego menu aplikacji [DZE], [KLU], [BUD]. 

 pojedynczo lub grupowo (fence): z menu: [Tools]->[Obiektowanie] 

Po poprawnym utworzeniu obiektu, tekst (centroid) przenoszony jest na warstwę 
TEMP. 

Przypadki nieutworzenia obiektu: 

 nie znaleziono obwiedni 

o zwiększyć ilość iteracji (powiększyć obszar szukania elementów 
obwiedni) 

o użyć shapy do obiektowania 

o poprawić topologię 

 w znalezionej obwiedni istnieją jeszcze inne teksty o różnej wartości 
(obiektowanie z użyciem fence) - miejsca te wskazywane są na warstwie 
ERROR 

 

Dodatkowo w celu usprawnienia opracowania warstwy klasoużytków istnieje 
możliwość obiektowania poprzez wskazanie centroidu (tekstu), a następnie 
punktów wewnątrz obszarów zamkniętych, gdzie występuje ten sam klasoużytek – 
[iMaper]->[Ustawienia]:Obiektowanie KLU. 
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UWAGA! 

Podczas obiektowania wyszukiwane są enkalwy wewnątrz obiektu. W takich 
przypadkach tworzony jest shape zewnętrzny do którego dopięte są atrybuty oraz 
shapy (enklawy) wewnętrzne jako obiekt typu dziura (hole). Shapy te są łączone w 
jedną grupę graficzną. 

3.2 Import danych 

Menu importu: [Tools]->[Import] 

 

W trakcie importu możliwe jest wykonanie transformacji pomiędzy układami 
współrzędnych. 

Opis formatów importu: 

 ASCII iMaper: wewnętrzny format wymiany danych, umożliwia 
transformację pomiedzy układami oraz łączenie danych z różnych źródeł. 
Wykorzystywany jest również do ingerencji w dane z poziomu pliku 
tekstowego. 

 ASCII iMaper -> Test: możliwość importu obiektów powierzchniowych jako 
linie i teksty. 

 OZR X Y STB ZRD BPP RKRG: wczytywanie kompletu danych do punktów 
granicznych – separator spacja lub tab. 

 SWDE->Punkty: wczytanie punktów granicznych z pliku SWDE. 

 SWDE->Obiekty 1, Obiekty 2: wczytanie obiektów (działki, budynki, 
klasoużytki…) z pliku SWDE. Standardowo wykorzystywany jest import 
SWDE->Obiekty 1, w przypadku problemów można spróbować SWDE-
>Obiekty 2. 

 Nr X Y (Atrybuty): wczytywanie punktów pikiety – atrybuty są jako opcja - 
separator spacja lub tab. 

 Tango GeoInfo - import danych z formatu giv lub tng, obiekty i atrybuty są 
interpretowane na podstawie pliku exp (przykładowe pliki dołączone z 
aplikacją) - opis: 

lvl:DZE=GESDZI   obiekt GESDZI importowany na warstwie DZE 

lvl:ROW.1=GSLROS  obiekt GSLROS importowany na  warstwie  
     ROW z atrybutem ityp=1 

lvl:TEL_A>MUF=GUPTZK obiekt GUPTZK importowany na  warstwie  
     TEL_A jako symbol (cell) MUF 



 
iMaper Adam Marcisz, ul. Wodna 21B, 44-240 Żory,  e-mail: imaper.biuro@gmail.com             NIP 651-105-44-48 

Tytuł: iMaper - opis aplikacji 

Dotyczy: Aplikacja do wspomagania prac związanych z EGiB, BDOT500, GESUT 

 

Autor: Adam Marcisz 

Wersja: 2.0 

Data: sierpień  2015 

 

7/25  

tag:dze.rkrg=KRG.n  atrybut KRG.n importowany jako rkrg 

txt:PIK=NRI;KRG.n;MPD.n atrybuty NRI, KRG.n, MPD.n jako tekst 

 

 Punkty -> CSV: pliki z danymi do punktów granicznych w formacie 
wykorzystywanym przez Algeo. 

 Obiekt X Y Z Lvl Tagi - import roboczy - w trakcie opracowania. 

 EWMAPA - import działek w formacie edz. 

 XML - działki - import działek z plików XML (ARiMR). 

 X Y (Z), Y X (Z): punkty wczytywane jako okręgi z opcją 3D. 

 Cell X Y (Skala Kat Lvl Tagi): wczytywanie bloków (cell) z pliku 
tekstowego gdzie Cell = nazwa bloku, Skala, Kąt, Lvl Tagi – opcjonalnie. 

 Cell X Y Z - import bloków 3D 

 DTM ASC - import danych DTM w formacie ASC (GUGiK) - 3D 

 Import SHP - import przy pomocy modułu shpdgn.ma - patrz opis aplikacji. 

3.3 Wstawianie punktów pikiety/punktów granicznych 

Menu główne aplikacji - przycisk [PKT]. 

 
Po wskazaniu punktu pojawia się okno dialogowe. W przypadku włączonej opcji 
Pik wstawiany jest tekst na warstwie PIK np: 1;KERG;O - pod uwagę brane są 
pola OZR, RKRG, ZRD oraz STB i BPP gdy STB jest różne od Nie dotyczy. 

W przypadku wyłączonej opcji Pik wstawiany jest punkt graniczny (okrąg) na 
warstwie PZG z atrybutami: OZR, RKRG, BPP, ZRD, STB, Cecha. Atrybut Cecha 
jest atrybutem wewnętrznym wykorzystywanym przy realizacji podziałów. 

W przypadku wstawiania punktu granicznego na istniejącej pikiecie, przejmowane 
są jej atrybuty. 

Symbolika wstawianych punktów definiowana jest w menu: [iMaper]-
>[Ustawienia]. 

3.4 Narzędzia ułatwiające rysowanie obiektów 

 IPLS - rysowanie ortogonalne 

 IOBR - rysowanie obrysów obiektów 
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4 Obliczenia 

4.1 Obliczenia ortogonalne oraz wcięcie liniowe 

Bardzo często w przypadku starszych operatów pomiarowych lub w przypadku 

uzupełnienia pomiarów tachimetrycznych wykorzystywana jest metoda ortogonalna lub 

metoda wcięcia liniowego. Optymalne narzędzie do takich obliczeń pozwala w wielu 

przypadkach zaoszczędzić sporo czasu. Narzędzie zawarte w aplikacji pozwala na takie 

obliczenia oraz na sporządzenie z nich dokumentacji. 

Wywołanie polecenia – menu główne [ORTO], a następnie wskazanie początku i końca 

linii pomiarowej. Pojawia się następujące menu: 

 

Omówienie poszczególnych pól menu: 

- Dł. pomierzona: długość stwierdzona w terenie, podanie wartości powoduje 

wprowadzenie do obliczeń poprawki. 

- Zero: w przypadku gdy nasza linii nie rozpoczyna się od punktu pomiarowego 0.00, 

podajemy wartość jaką stwierdzono na tym punkcie i dalsze obliczenie wykonujemy 

bez konieczności odejmowania wartości początkowej. 

- Zapisz oblicz.: powoduje zapisanie obliczeń do pliku nazwa_pliku_dgn.obl, dane o 

punkcie początkowym oraz końcowym są pobierane z rysunku z elementów typu punkt 

graniczny lub tekst; obliczenia są dopisywane do istniejącego pliku. 

- OZR[inny]: określa do którego pola powraca kursor po obliczeniu punktu. 

- Wcięcie liniowe: odcięta i rzędna traktowane są jako długości do wcięcia liniowego, 

wartości dodatnie – punkt po „prawej” stronie linii pomiarowej, jedna lub dwie 

wartości ujemne – punkt po „lewej” stronie linii. 

- RKRG, BPP, ZRD, STB, OZR: atrybuty punktu/pikiety; jeżeli podane zostaną 

wartości BPP i ZRD wstawiony zostanie punkt graniczny, jeżeli nie to punkt pikiety. 
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4.2 Obliczenia pól powierzchni działek i klasoużytków 

Obliczenie pól powierzchni z wykazem oznaczeń i współrzędnych punktów 

wierzchołkowych: [Tools]->[Obliczenie pól DZ] lub [Obliczenie pól KLU]. Dla działek 

wskazanych w (fence) tworzony jest raport z obliczenia pól / obliczenia pól klasoużytków 

w działce. W przypadku obliczania pól działek aplikacja sprawdza obecność punktów 

granicznych na załamaniach. Brak takich punktów sygnalizuje jako błąd. W przypadku 

obliczania pól klasoużytków w działkach aplikacja sprawdza obecność punktów 

granicznych lub punktów pikiety. Brak punktów sygnalizowany jest jako błąd. Błąd 

sygnalizowany jest wstawieniem punktu pikiety o kolejnym numerze co w przypadku 

obliczania pól klasoużytków pozwala na zanumerowanie wszystkich załamań i przecięć z 

granicami działek. 

Przykład obliczenia pól działek: 

Nr działki;Obręb;Arkusz;Powierzchnia 

 27/1;1;;0.0264 

NRP;OZR;X;Y;Czołówka 

D.301103_2.0001.100055;603;5677545.01;3700145.87;17.90 

D.301103_2.0001.100056;604;5677547.68;3700128.17;91.88 

D.301103_2.0001.100058;606;5677456.82;3700114.49;80.76 

D.301103_2.0001.100057;605;5677536.42;3700128.10;16.29 

D.301103_2.0001.100054;602;5677533.99;3700144.21;11.14 

Nr działki;Obręb;Arkusz;Powierzchnia 

 312/1;1;;0.2231 

NRP;OZR;X;Y;Czołówka 

D.301103_2.0001.100054;602;5677533.99;3700144.21;9.52 

D.301103_2.0001.100037;584;5677524.58;3700142.79;31.26 

D.301103_2.0001.100038;585;5677493.66;3700138.21;31.46 

D.301103_2.0001.100041;589;5677462.54;3700133.55;30.41 

D.301103_2.0001.100039;587;5677432.47;3700129.04;30.91 

D.301103_2.0001.100031;578;5677401.90;3700124.46;21.90 

D.301103_2.0001.100059;607;5677416.65;3700108.27;40.65 

D.301103_2.0001.100058;606;5677456.82;3700114.49;80.76 

D.301103_2.0001.100057;605;5677536.42;3700128.10;16.29 

 

Przykład obliczenia pól klasoużytków: 

Działka Obręb Arkusz Pow.[ha] 

312/1 1 0 0.2231 

KLU Pow.[ha] Identyfikator 

Br/RII 0.0903 Id:0 

Lp. Współrzędna X Współrzędna Y NRP OZR 

1 5677459.99 3700115.03 KLU 1 

2 5677456.82 3700114.49 D.301103_2.0001.100058 606 

3 5677416.65 3700108.27 D.301103_2.0001.100059 607 

4 5677401.90 3700124.46 D.301103_2.0001.100031 578 

5 5677416.35 3700126.63 KLU 2 

6 5677432.47 3700129.04 D.301103_2.0001.100039 587 
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7 5677457.16 3700132.74 KLU 3 

8 5677459.99 3700115.03 KLU 1 

KLU Pow.[ha] Identyfikator 

RII 0.1329 Id:0 

Lp. Współrzędna X Współrzędna Y NRP OZR 

1 5677459.99 3700115.03 KLU 1 

2 5677457.16 3700132.74 KLU 3 

3 5677462.54 3700133.55 D.301103_2.0001.100041 589 

4 5677493.66 3700138.21 D.301103_2.0001.100038 585 

5 5677524.58 3700142.79 D.301103_2.0001.100037 584 

6 5677533.99 3700144.21 D.301103_2.0001.100054 602 

7 5677536.42 3700128.10 D.301103_2.0001.100057 605 

8 5677459.99 3700115.03 KLU 1 

4.3 Rozliczenie pól klasoużytków w działkach 

Menu: [Tools]->[Rozliczenie] 

 

Rozliczenie może być wykonane razem z porównaniem z częścią opisową EGiB lub bez. 

Część opisowa EGiB musi być zapisana w postaci pliku tekstowego z rozszerzeniem: 

*.klu. Przykład pliku: 

149;R/RV;0.150000;0.380000 

149;R/RVI;0.230000;0.380000 

174/10;dr;0.184000;0.184000 

305/3;R/RIVa;0.360000;2.418900 

305/3;R/RIVb;1.560900;2.418900 

305/3;R/RVI;0.498000;2.418900 

Jeżeli działki mają informację o podziale arkuszowym to zapis w pliku *.klu jest 

następujący: 

AR_1.149;R/RV;0.150000;0.380000 

AR_1.149;R/RVI;0.230000;0.380000 

Pliki *.klu mogą zawierać dane tylko z jednego obrębu. 

Opcje rozliczenia: 

- Standardowe: typowe rozliczenie bez dodatkowych opcji. 

- Użytki LPIS: rozliczenie oraz porównanie z częścią opisową EGiB i wykazanie 

rozbieżności, które nie powinny mieć miejsca w projekcie LPIS – wymagany plik 

*.klu. 

- Bez zmiany B: rozliczenie z rozrzuceniem poprawki na pozostałe użytki w działce. 
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- Wstawienie etykiet: wstawienie etykiet na części wspólnej działki i klasoużytku. 

Etykiety są wstawiane w postaci tekstów na warstwie 50. Kolor, styl i czcionka są wg 

bieżących ustawień MicroStation. 

- Kontrola Br: na podstawie pliku *.br z wykazem działek jest wykonywana kontrola, 

czy na danej działce powinien być użytek B czy Br. W pliku *.br podajemy numery 

działek, które należą do osób zarejestrowanych jako rolnicy. Numery działek podajemy 

w kolejnych wierszach np.: 123/45 lub AR_1.123/45. 

- Procent: w przypadku porównania z częścią opisową EGiB, działki dla których 

zmiany przekraczają podany procent powierzchni lub posiadają inne oznaczenia 

klasoużytków są zapisywane do pliku raportu. 

- Zapis w DB: zapis rozliczonych pól klasoużytków w bazie danych. Konieczne 

połączenie z bazą. 

- Filtruj kolor: do rozliczenia są brane tylko te działki, które mają kolor jak podany w 

oknie dialogowym. 

W trakcie rozliczenia są sprawdzane błędy, małe powierzchnie oraz rozbieżności z częścią 

opisową EGIB. Informacje te prezentowane są w grafice w następujący sposób (kolor, styl 

i czcionka wg ustawień [iMaper]->[Ustawienia]->Parametry TERROR]: 

 Błędy związane z niezgodnością sumy pow. działki i klasoużytków: shape – 

warstwa 50. 

 Małe powierzchnie: (poniżej 20 m) shape – warstwa 51. 

 Rozbieżności pomiędzy częścią opisową i grafiką: teksty – warstwa 48 i 49. 

Uwaga! W przypadku, gdy chcemy dopiero utworzyć klasoużytki na działkach możemy 

zrobić rozliczenie bez warstwy klasoużytków i aplikacja wygeneruje informację na 

działkach jakie klasoużytkie są na nich wg części opisowej EGiB. Na warstwie 48 będą 

informacje gdzie na działce występuje więcej niż jeden klasoużytek, a na warstwie 49, 

gdzie jest tylko jeden klasoużytek – można wtedy na tych działkach automatycznie 

zobiektować klasoużytki. 

Przykłady raportów z rozliczenia: 

 Rozliczenie standardowe bez porównania z EGIB: 

185 1 0 0.2370 B 0.1395 

185 1 0 0.2370 RV 0.0975 

186 1 0 0.2185 Br/RV 0.1658 

186 1 0 0.2185 RV 0.0527 

187 1 0 0.2125 B 0.1074 

187 1 0 0.2125 RV 0.1051 

 Rozliczenie standardowe z porównaniem z EGIB: 

36 1 0 0.2400 B 0.0490 0.0538 

     RII 0.0500 0.0607 

     RIIIa 0.1410 0.1255 

     Razem: 0.2400 0.2400 

Raporty z rozliczenia można w prosty sposób zaimportować do Excel’a i utworzyć wykaz 

zmian gruntowych. 
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4.4 Porównanie działek z częścią opisową EGiB 

Polecenie: [Tools]->[Porównaj DZ]. Do porównania potrzebny jest plik tekstowy z 

danymi z części opisowej EGiB - *.dz. Format pliku wygląda następująco – 

numer_działki;powierzchnia_działki np.: 123/45;0.0950 lub AR_2.123/45;0.0950. 

Z porównania powstaje raport w pliku tekstowym oraz informacje w postaci tekstów w 

grafice: warstwa 50. 

Uwaga! Działki rozłączne (w dwóch kawałkach) są sumowane i w raporcie z porównania 

oraz w rozliczeniu klasoużytków są traktowane jako jedna działka. Sytuacja taka jest 

jednak sygnalizowana jako błąd: „powtórzona działka”. 

Przykład raportu z porównania: 

14 1 0 3.3900 3.4635 0.0053 0.0735 przekroczona odchyłka 

15/1 1 0 0.5425 0.5429 0.0007 0.0004  

15/2 1 0 2.3296 2.3293 0.0090 0.0003  

5 Narzędzia do klasoużytków 

5.1 Zamiana klas i użytków na klasoużytki 

Polecenie: [Tools]->[Zamień na klasoużytki]. Po imporcie danych ewidencyjnych z 

formatu SWDE warstwa klasoużytków jest rozdzielona na klasy [KKL] oraz użytki 

[UZG]. Obiekty te należy zamienić na klasoużytki w celu przeprowadzenia obliczeń i 

rozliczeń z działkami. 

5.2 Scalenie klasoużytków 

Polecenie: [Tools]->[Scal klasoużytki]. Polecenie szczególnie przydatne po opracowaniu 

klasoużytków oddzielnie dla każdej działki ewidencyjnej. Scalane klasoużytki muszą 

oprócz oznaczenia mieć ten sam obręb ewidencyjny. Można wyłączyć scalenie dróg 

używając opcji [iMaper]->[Ustawienia]->[Opcje dodatkowe iMaper]. 

6 Narzędzia do budynków 

6.1 Dopisanie informacji do budynków 

Polecenie: [Tools]->[Dopisz dz. do bud.]. Na podstawie położenia dopisywane są 

następujące informacje: działka na której znajduje się budynek lub jego największa część, 

arkusz ewidencyjny, obręb, powierzchnia zabudowy. 

6.2 Porównanie z częścią opisową EGiB 

Polecenie: [Tools]->[Porównaj budynki]. Wymagany jest plik tekstowy *.bud z 

informacją z części opisowej EGiB w formacie: 

działka;identyfikator;funkcja;kondygnacje;pow. zabudowy 

Np.: 

AR_1.6/4;123;m;1;24.5 

AR_1.7;124;m;2;123.4 

AR_1.7;125;i;1;32.2 
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W wyniku porównania wyświetlane są błędy w części graficznej jako tekst na warstwie 50 

oraz tworzony plik tekstowy z budynkami, które nie zostały skojarzone z częścią 

graficzną. 

6.3 Kontrola budynków z klasoużytkami 

Polecenie: [Tools]->[Test BUD->KLU]. Sprawdzane jest położenie budynku na 

odpowiednim klasoużytku. Np.: budynek „i” powinien być na klasoużytku „B, Bi, Ba”. 

Sprawdzane jest również czy cały budynek jest położony na właściwym klasoużytku. 

Błędy wyświetlane są w postaci tekstów na warstwie 50. 

7 Eksport danych 
Polecenie: [Tools]->[Export]. Eksport wykonywany jest w zakresie zdefiniowanym przez 

„fence”. W trakcie eksportu możliwe jest wykonanie transformacji współrzędnych. 

 

Omówienie formatów eksportu danych: 

 ASCII iMaper – wewnętrzny format exportu/importu do wymiany pomiędzy 

projektami oraz do transformacji grafiki. 

 Punkty CSV – pliki z danymi do punktów granicznych w formacie wykorzystywanym 

przez Algeo. 

 Teksty & Kółka – plik z prostym wykazem współrzędnych: x y z warstwa lub tekst x y 

z warstwa. 

 Tango GI2000 – eksport do GeoInfo 2000 – tylko obiekty ewidencyjne. 

 Tango GI V – eksport do GeoInfo V – tylko obiekty ewidencyjne. 

 SHP Działki | SHP Klasoużytki – wywołanie aplikacji zewnętrznej shpdgn.ma 

 EWMAPA – eksport do EWMAPY – tylko obiekty ewidencyjne. 

 Tango iMaper – eksport do ogólnego formatu Tango. 

8 Przeglądanie (szukanie) obiektów 
Do wyszukiwania obiektów służy przycisk z głównego menu aplikacji: [ >> ]. W 

zależności od wartości w polach: [Obręb], [Arkusz], [Szukaj] wyszukiwane są inne 

elementy. Pole [Szukaj] zawsze musi być wypełnione. 

 Jeżeli pola [Obręb], [Arkusz] są równe „0” wyszukiwane są elementy: line, text, shape, 

circle z nazwy warstwy podanej w polu: [Szukaj]. Dodatkowo, jeżeli włączona jest 

opcja: [iMaper] -> [Ustawienia] -> [Opcje dodatkowe iMaper], po powiększeniu 

obiektu w bieżącym widoku jest on usuwany. Funkcja ta jest bardzo przydatna podczas 
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przeglądania błędów. Jeżeli pola [Obręb], [Arkusz] mają wartość „0”, a pole [Szukaj] 

jest puste wyszukiwane są elementy z warstwy „ERROR”. 

 Jeżeli pole [Obręb] jest większe od zera, wyszukiwana jest działka o numerze podanej 

w polu: [Szukaj]. Dodatkowo, jeżeli pole [Arkusz] jest większe od zera, w trakcie 

wyszukiwania sprawdzana jest zgodność arkusza mapy. 

9 Narzędzia do przetwarzania rastrów 

9.1 Wczytywanie rastra poprzez wskazanie punktu 

Polecenie: [Raster]->[Wczytaj raster – punkt]. Przed wywołaniem tego polecenia należy 

ustawić właściwy układ geodezyjny i skalę map – patrz [iMaper]->[Ustawienia]. Na 

podstawie punktu wyliczane jest godło mapy i we wskazanym katalogu wyszukiwany jest 

plik *.tif o takiej nazwie. Po wskazaniu rastra narzędzie automatycznie przechodzi do 

wczytywania kolejnego punktu.  

 

Istnieje możliwość obliczania godeł (nazwy plików) z innego układu geodezyjnego niż ten 

w którym pracujemy. Funkcja przydatna w sytuacji gdy mamy np.: rastry w kroju 

sekcyjnym w układzie 1965s5, a pracujemy w układzie 2000s18. Rastry z układu 1965s5 

muszą być wcześniej przetransformowane do układu 2000s18 – patrz [Raster]-

>[Transformacja rastrów]. W opisanym przypadku należy ustawić układ 1965s5 i 

uaktywnić [Raster]->[Transformacja rastrów]: 
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Po tych ustawieniach nacisnąć przycisk [Anuluj]. W takim ustawieniu pomimo, że 

pracujemy w układzie 2000s18, obliczane są godła z układu 1965s5. 

9.2 Wczytywanie rastra poprzez wskazanie tekstu 

Polecenie: [Raster]->[Wczytaj raster – text]. Należy wskazać tekst w rysunku głównym 

lub w rysunku referencyjnym. Na podstawie tego tekstu generowana jest nazwa pliku 

rastrowego i jest on wyszukiwany we wskazanym katalogu. 

9.3 Transformacja rastrów. 

Polecenie: [Raster]->[Transformacja rastrów]. 

 

Funkcja ta pozwala na transformację rastrów pomiędzy układami geodezyjnymi. Istnieje 

możliwość transformacji plików w formacie GEOTIFF lub z plikiem nagłówkowym GEO. 

W przypadku gdy mamy do czynienia z plikami monochromatycznymi i mamy 

uruchomioną aplikację Iras/B, transformacja wykonywana jest w oparciu o polecenia tej 

aplikacji wraz z „resamplingiem” rastra. W przypadku gdy mamy inny format pliku lub 

gdy nie mamy aktywnej aplikacji Iras/B, transformacja wykonywana jest w środowisku 

MicroStation. Pliki rastrowe są transformowane w oparciu o cztery punkty wierzchołkowe. 

Uwaga! Pliki rastrowe są nadpisywane z parametrami właściwego układu. Plik *.geo 

pozostaje bez zmian. 

Istnieje możliwość utworzenie plików konfiguracyjnych *.map wykorzystywanych przez 

oprogramowanie OziExplorer. 

9.4 Wczytywanie rastrów na podstawie plików *.geo 

Polecenie: [Raster]->[Wczytaj GEO]. Wczytanie rastrów na podstawie plików 

nagłówkowych *.geo. 

10 Transformacja danych 
Transformacja danych możliwa jest w przypadku importu, eksportu, obliczania godeł oraz 

transformacji rastrów. Zawarte układy to: 2000, 1965, 1992, WGS, 1942, SGROW. W 

przypadku przeliczeń z lub do układu 1965 uwzględniane są korekty empiryczne. Możliwe 

jest utworzenie własnego pliku transformującego poprzez plik *.lok generowany z programu 

Unitrans. Przykład pliku *.lok: 

1.60491724385954E-0004     skala 

14205.51227 25654.71955    xs1 ys1 

5625320.21091 3782305.38273    xs2 ys2 

3.92058341753951E-0003 1.00729204536788E-0003  a0 b0 
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6.22953494897811E+0003  -5.07773799332713E+0001 a1 b1 

1.85945506721547E-0002 1.00793537841922E-0002 a2 b2 

Istnieje możliwość połączenia transformacji z pliku *.lok z transformacją zawartą w 

aplikacji – np.: z układu lokalnego do układu 1965, a następnie do układu 2000. 

Transformacja wg pliku *.lok jest wykonywana zawsze przed transformacją zdefiniowaną. 

Uwaga! Przeliczanie pomiędzy układami nie jest weryfikowane w sensie logicznym i 

podanie niepoprawnych układów może spowodować przerwanie działania aplikacji. 

11 Narzędzia wspomagające rysowanie 

11.1 Rysowanie ortogonalne, kartowanie – ipls 

Narzędzie do digitalizacji budynków oraz innych obiektów ortogonalnych oraz do 

rysowania budynków z pomiaru. Wywołanie polecenia odbywa się z linii poleceń 

MicroStation, wpisując: ipls parametr. Parametr to wartość, do której będzie wymuszany 

kąt prosty np.: ipls 0.30. Linia bazowa definiowana jest na bazie pierwszego odcinka i kąt 

prosty lub kąt 180 jest w odniesieniu do tego odcinka. W trakcie rysowania można w oknie 

dialogowym podawać długości boków, można zmienić odcinek bazowy na odcinek 

poprzedni [x], można odwrócić przebieg linii [k]. Użycie funkcji snap anuluje zadany 

parametr kąta prostego. 

11.2 Rysowanie obrysów – iobr 

Narzędzie do rysowania obrysów obiektów – np.: rura ochronna. Wywołanie polecenia 

odbywa się z linii poleceń MicroStation, wpisując: iobr parametr. Parametr to połowa 

szerokości obrysu – np.: iobr 0.5 

12 Definiowanie ramek sekcyjnych 

12.1  Ramka sekcyjna przez wskazanie punktu 

Polecenie: [iMaper]->[Wstaw ramki sekcyjne]. Wskazując punkt na mapie wstawiana jest 

ramka sekcyjna w wybranym układzie współrzędnych i skali (patrz [iMaper]-

>[Ustawienia]) wraz z opisem pozaramkowym. Warstwa na której są rysowane sekcje ma 

nazwę „SEKCJE”, pozostałe atrybuty: kolor, grubość oraz styl wstawienia elementów 

ramki jest na podstawie aktualnych ustawień MicroStation. W opisie wstawiane są 

wyliczane wartości tekstów oraz teksty do podmiany. Ramka posiada również przykrycie 

treści mapy pod opisem. Podmiany tekstów oraz kolorystykę warstw należy zdefiniować w 

pliku konfiguracyjnym *.tbl. 

Uwaga! W opisanym powyżej przypadku nie może istnieć zdefiniowany w rysunku 

„fence”. 

12.2  Podział sekcyjny w zakresie „fence” 

Polecenie: [iMaper]->[Wstaw ramki sekcyjne] – („fence” musi być zdefiniowany). W 

zakresie wskazanym przez „fence”, na warstwie „SEKCJE”, aktywnym kolorem, stylem i 

grubością, zostaną wstawione ramki sekcyjne z numerami godeł. Istnieje możliwość 

wstawienia podziału sekcyjnego z innego układu współrzędnych geodezyjnych niż 

rysunek, w którym pracujemy. Należy określić w jakim układzie mają być wstawione 
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sekcje (patrz [iMaper]->[Ustawienia]), a następnie włączyć „transformację” w jednym z 

okienek dialogowych: 

[Import], [Export] lub [Transformacja rastrów]. 

Uwaga! W ustawieniach jest do wyboru podział sekcyjny w układzie 1942, podany w 

nawiasach. W tym przypadku układ sekcyjny bazuje na układzie współrzędnych 1992, a 

generowany jest podział sekcyjny z układu 1942. 

Uwaga! Podział sekcyjny map układu 1992 i 1942 jest generowany dla skali 1:5000 i 

mniejszej. 

13 Dopisywanie do obiektów dodatkowych atrybutów. 
Polecenie: [Tools]->[Dodaj atrybut]. 

 

Narzędzie powstało na potrzebę dopisania oznaczenia KERG do działek ewidencyjnych. 

Dla wybranych obiektów wyszukiwany jest tekst z podanej warstwy (wewnątrz lub na 

punkcie) i jeżeli zostanie znaleziony, zostanie dopisany jako atrybut (tag) do elementu. 

Nazwę taga należy podać w polu [Tag]. W przypadku znalezienia większej ilości tekstów 

spełniających zadane kryterium o różnych wartościach, zamiast dołączenia atrybutu 

sygnalizowany jest błąd. Podobnie jest w sytuacji, jeżeli element posiada dołączony tag o 

zadanej nazwie i jego wartość jest różna od wartości znalezionego tekstu. 

14 Przygotowanie informacji o podziałach, scaleniach, 
wznowieniu działek 

Zapis działek i ich relacji z punktami granicznymi oraz z działkami sąsiednimi wymaga 

odpowiedniego przygotowania rysunku. Przygotowanie rysunku polega na odpowiednim 

wprowadzeniu informacji o podziale/wznowieniu działki oraz o punktach granicznych. W 

tym celu należy wykonać następujące czynności: 

 Wprowadzić nowe punkty graniczne lub zmodyfikować informację o punktach 

istniejących – w szczególności stabilizację oraz cechę: [EDP] – edycja punków. 

 Usunąć stare działki, wprowadzić nowe działki oraz nadać im odpowiednie cechy: 

[Baza]->[Ustaw cechę dla działek] 

 

Do wyboru mamy następujące cechy: 

- nieznana: domyślna dla działek, które nie podlegają opracowaniu. 
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- główna: dla działek, które są głównym przedmiotem roboty np.: wydzielenie 

drogi – działki główne to te, które będą stanowiły drogę, podział działki na 

działki budowlane – wszystkie działki budowlane. 

- inna pomiar: pozostała część działki po wydzieleniu działki głównej, której 

granice zostały pomierzone. 

- inna potrącenie: pozostała część działki po wydzieleniu działki głównej, której 

granice nie zostały pomierzone. 

 Wstawić numer dotychczasowy dla nowych działek jako tekst – domyślnie na warstwie 

14 (PODZIAL). Warstwę tę można zmienić z poziomu: [iMaper]->[Ustawienia]-

>[Stary num.dz.]. Dla działek, dla których wznawiamy granice stary numer może być 

taki sam jak nowy. 

Uwaga! Dla działek „głównych” oraz „inna pomiar” wszystkie punkty graniczne muszą 

mieć informację z weryfikacji w terenie: cecha. 

W trakcie zapisu  podziałów, poprawność danych jest szczegółowo weryfikowana. Na 

warstwie 50 wyświetlane są komunikaty z opisem błędu. 

15 Współpraca z bazą danych 
Istnieje możliwość współpracy z bazą danych w formacie MS Access poprzez podanie 

źródła ODBC. Źródło ODBC musi być zdefiniowane w systemie, a odwołanie do niego 

realizowane jest przez plik: nazwa_pliku_dgn.ini. Plik *.ini o nazwie takiej samej jak 

aktywny plik *.dgn musi być w tym samym katalogu. Plik *.ini jest plikiem tekstowym o 

następującej składni: 

ODBC[tab]nazwa_źródła_odbc 

GMINA[tab]teryt_gminy 

15.1 Pobierz dane podmiotowe 

Polecenie: [Baza]->[Pobierz dane podmiotowe]. Należy wskazać działkę, dla której 

zostaną pobrane z bazy danych informacje o: powierzchni, KW, jednostce rejestrowej, 

właścicielach. 

15.2 Pobierz dane o klasoużytkach 

Polecenie: [Baza]->[Pobierz dane KLU]. Należy wskazać działkę, dla której zostaną 

pobrane z bazy danych informacje o: oznaczeniu klasoużytków i ich powierzchni. 

15.3 Zaznacz działki z bazy 

Polecenie: [Baza]->[Zaznacz działki z bazy]. 

 

Działki zaznaczane są wybranym kolorem. 

Opcje filtrowania działek: 
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 KW [równe]: zaznaczone zostaną działki o dokładnie takiej same wartości KW ja 

wpisana w okienku. Małe i wielkie litery mają znaczenie. 

 Właściciel [fraza]: zaznaczone zostaną działki, gdzie fragment nazwy właściciela lub 

władającego w inny sposób jest zgodny z wartością wpisaną w okienku. Małe i wielkie 

litery nie mają znaczenia. 

 Wyświetl KW [level]: na działkach zostanie wyświetlona wartość KW jako tekst na 

podanym numerze warstwy. Wybranym kolorem zostaną wyświetlone numery 

zweryfikowane, kolorem z [Ustawienia]->[Parametry ERROR] numery z ewidencji 

gruntów. 

 Brak działki w bazie: zaznaczone zostaną działki, które nie mają odpowiednika w 

bazie. 

 KW – zgodne: zaznaczone zostaną działki, których oznaczenie KW po weryfikacji jest 

zgodne z KW z ewidencji. 

 KW – niezgodne: zaznaczone zostaną działki, których oznaczenie KW po weryfikacji 

jest niezgodne z KW z ewidencji. 

15.4 Zapisz podziały robocze / ostateczne 

Polecenie: [Baza]->[Zapisz podziały robocze] lub [Zapisz podziały ostateczne]. Dane o 

podziałach muszą być wcześniej przygotowane w odpowiedni sposób – patrz rozdział: 

Przygotowanie informacji o podziałach, scaleniach, wznowieniu działek. W przypadku 

gdy dysponujemy roboczymi numerami działek nowoutworzonych zaleca się użycie 

polecenia [Zapisz podziały robocze], w przypadku numerów ostatecznych [Zapisz podziały 

ostateczne]. Do bazy zapisywane są następujące informacje: 

 Nowe numery działek, pow. graficzna, cecha działki. 

 Relacja stary numer działki – nowy numer. 

 Relacja z działkami sąsiednimi na podstawie cech punktów granicznych – zawsze 

zapisywana jest najważniejsza informacja o punkcie granicznym w następującej 

hierarchii: nowy, wznowiony, nieodnaleziony, odnaleziony, brak informacji. 

Dodatkowo tworzony jest tekstowy plik *.div z informacją o działkach i punktach 

granicznych w relacjach pomiędzy sobą. 

15.5 Działki do weryfikacji 

Polecenie: [Baza]->[Działki do weryfikacji]. Działki zaznaczone poprzez „fence” zostaną 

zapisane jako działki, które mają zostać zweryfikowane przed w celu opracowania 

dokumentacji do podziałów. 

15.6 Działki do okazania 

Polecenie: [Baza]->[Działki do okazania]. 
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Z poziomu grafiki można wyznaczyć działki, których granice będą okazywane we 

wskazanym miejscu i czasie. Na podstawie tych informacji wygenerować można 

zawiadomienia z bazy o okazaniu granic. Czas i miejsce okazania dla wybranych działek 

wyświetlane jest również w postaci tekstów na warstwie 21. 

Przykładowy zapis: 2009:04:10:10:00:Żory ul. Stodolna 31 

15.7 Sprawdź nowe działki 

Polecenie: [Baza]->[Sprawdź nowe działki]. Kontrola czy dane w bazie odpowiadają 

danym graficznym. W przypadku zmian zostanie wyświetlony na warstwie 50 komunikat 

o stwierdzonej rozbieżności. 

15.8 Usuń podziały z bazy 

Polecenie: [Baza]->[Usuń podziały z bazy]. Polecenie usuwa wszystkie zapisane 

informacje w bazie załadowane przez polecenia: [Baza]->[Zapisz podziały robocze] lub 

[Zapisz podziały ostateczne]. Nie ma możliwości usunięcia danych zapisanych 

poleceniami: [Baza]->[Działki do weryfikacji] i [Baza]->[Działki do okazania]. 
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ROZDZIAŁ II - Topol 

16 TOPOL – kontrola i automatyczna korekta topologii 
Aplikacja do ogólnych zastosowań przy kontroli i korekcie topologii rysunków CAD. 

 

Uruchomienie aplikacji: 

- z linii poleceń: mdl load topol 

- z menu iMaper: [Tools]->[Topologia] 

17 Opis parametrów działania aplikacji 
Elementy, które są testowane i/lub korygowane w trakcie działania aplikacji to: obiekty 

(LINE, LINESTRING, SHAPE) oraz punkty (CIRCLE, TEXT). 

17.1 Parametry zaznaczania błędów 

Błędy zaznaczane są w postaci obiektów typu: line, shape, circle. Warstwa, kolor, grubość 

oraz styl linii są wybierane przez użytkownika. Dodatkowo dla elementów typu circle 

ustalany jest promień. W przypadku niektórych opcji testowania obiektów i włączonej auto 

korekcie, elementom korygowanym jest zmieniana symbolika na zadane wartości. 

17.2 Parametry testowania obiektów 

 Offset: odległość punktu i od boku obiektu. Jeżeli offset jest równy zero, parametr ten 

nie jest badany w trakcie działania aplikacji. 

 

 Zakres: odległość punktu/wierzchołka jednego obiektu od punktu/wierzchołka 

drugiego obiektu. Ogólnie wykorzystywany parametr przy badaniu relacji pomiędzy 

obiektami. 
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 AK: automatyczna korekta. W przypadku gdy jest wykonywany test, który ma 

dostępną opcję AK, możliwa jest automatyczna korekta błędów. 

 Snap: Opcja kontroli omówiona w dalszej części instrukcji. 

 View: aktywny widok, dla którego wykonywane są kontrole. 

18 Kontrole obiektów 
Kontrole zawsze są wykonywane w zakresie zdefiniowanym przez „fence”. 

18.1 Podwójne punkty/AK/Snap 

Kontrola podwójnych punktów (CIRCLE, TEXT) w odległości mniejszej od zadanej w 

polu Zakres. 

AK/Snap – dla elementów podwójnych zaznaczany jest błąd w postaci okręgu. 

AK/Snap – pierwszy testowany element, dla którego istnieje powtórzony element, jest 

zmieniany na symbolikę zadaną dla błędów. 

AK/Snap – jeżeli na warstwie błędów jest okrąg w odległości mniejszej od zadanej w polu 

Zakres od badanego elementu, to element ten jest przesuwany na jego miejsce. 

Pole Offset nie jest wykorzystywane w trakcie działania tego testu. 

18.2 Punkty na obiektach/AK/Snap 

Kontrola obiektów (LINE, LINESTRING, SHAPE) w relacji do punktów (CIRCLE, 

TEXT).  

AK/Snap, Offset = 0.00 – kontrola czy na wierzchołkach testowanych obiektów są punkty 

w odległości mniejszej od podanej w polu Zakres. Brak punktów sygnalizowany jest jako 

błąd w postaci okręgu. 

AK/Snap, Offset > 0.00 – kontrola czy w odległości mniejszej od zadanej w polu Offset 

od boku obiektu znajduje się punkt – jeżeli tak, jest on zaznaczany jako błąd w postaci 

okręgu. Odległość badanego punktu musi być większa od podanej w polu Zakres. 

AK/Snap, Offset = 0.00 – w przypadku wierzchołka obiektu, który jest w odległości 

mniejszej od podanej w polu Zakres i większej od 0.00, wierzchołek ten jest przesuwany 

na punkt. 

AK/Snap, Offset > 0.00 – w przypadku gdy w odległości mniejszej od podanej w polu 

Offset od boku obiektu znajduje się punkt, jest on dodawany jako punkt wierzchołkowy 

obiektu. 
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Czarna linia ciągła to obiekt przed modyfikacją, przerywana po modyfikacji. 

AK/Snap, Offset > 0.00 – w przypadku gdy w odległości mniejszej od podanej w polu 

Offset i większej od podanej w polu Zakres od boku obiektu znajduje się punkt, na 

warstwie błędów dodawany jest okrąg w miejscu rzutu prostopadłego punktu na bok 

obiektu. 

 

Niebieski okrąg to nowy punkt wstawiony w wyniku analizy. 

18.3 Spójność obszarów 

Kontrola przylegania obiektów typu SHAPE. Bok każdego elementu musi posiadać 

odpowiedni bok sąsiedniego elementu, którego wierzchołki są oddalone mniej niż 

odległość podana w polu Zakres. Boki elementów, które nie mają „pary” są wyświetlane 

jako linie na warstwie błędów. Pola Offset, AK, Snap nie są wykorzystywane. 

18.4 Podwójne wierzchołki/AK 

Kontrola występowania podwójnych wierzchołków w elementach typu SHAPE, LINE, 

LINESTRING. Pola Offset, Snap nie są wykorzystywane. 

AK – w przypadku kolejnych wierzchołków oddalonych od siebie mniej niż odległość 

podana w polu Zakres na warstwie błędów wstawiany jest okrąg. 

AK – w przypadku kolejnych wierzchołków oddalonych od siebie mniej niż odległość 

podana w polu Zakres powtórzony wierzchołek jest usuwany z obiektu. 

18.5 Podwójne teksty/AK 

Kontrola występowania podwójnych tekstów o tej samej wartości. 
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AK – w przypadku tych samych tekstów oddalonych od siebie mniej niż odległość podana 

w polu Zakres na warstwie błędów wstawiany jest okrąg. 

AK – w przypadku tych samych tekstów oddalonych od siebie mniej niż odległość podana 

w polu Zakres jednemu z nich zostaje zmieniona symbolika na symbolikę błędów. 

Offset, Snap nie są wykorzystywane. 

18.6 Niewykorzystane punkty/AK 

Znalezienie punktów (CIRCLE, TEXT), które nie są wierzchołkami obiektów (LINE, 

LINESTRING, SHAPE) -  

AK – w przypadku punktu, dla którego żaden wierzchołek obiektu nie znajduje się w 

odległości mniejszej od podanej w polu Zakres na warstwie błędów wstawiany jest okrąg. 

AK – w przypadku punktu, dla którego żaden wierzchołek obiektu nie znajduje się w 

odległości mniejszej od podanej w polu Zakres zostaje zmieniona symbolika na symbolikę 

błędów. 

Offset, Snap nie są wykorzystywane. 

18.7 Poprawność obiektów 

Kontrola poprawności elementów typu SHAPE. Poprawność sprawdzana jest tylko w 

obrębie elementu: powtórzone punkty, przecięcia boków, styczne punkty. Błędy 

zaznaczane są w postaci okręgów. 

Offset, AK, Snap nie są wykorzystywane. 

18.8 Nakładanie obszarów 

Kontrola nakładania się obiektów typu SHAPE. Jeżeli występują części wspólne są one 

zaznaczane jako obiekty powierzchniowe na warstwie błędów. 

18.9 Bagnety&Neary&Przecinanie 

Kontrola „niedosnapowań” oraz przecięć elementów typu LINE, LINESTRING, SHAPE. 

Brak „snapu” sprawdzany jest dla odległości podanej w polu Zakres. Błędy zaznaczane są 

w postaci okręgów. 

Offset, AK, Snap nie są wykorzystywane. 

18.10 Połącz linie 

Opcja łączenia elementów typu LINE w LINESTRING. W wyniku łączenia powstają 

łańcuchy linii od rozgałęzienia do rozgałęzienia. Przed uruchomieniem łączenia najlepiej 

rozbić wszystkie istniejące elementy typu SHAPE i LINESTRING. 

18.11 Punkty na prostej/AK 

Kontrola elementów typu LINESTRING i SHAPE pod kątem występowania sąsiednich 

wierzchołków w linii prostej w tolerancji mniejszej od podanej w polu Offset. 

Dodatkowym warunkiem kontroli jest brak punktów (CIRCLE, TEXT) na wierzchołkach 

spełniających pierwsze kryterium w odległości podanej w polu Zakres. 

AK – zaznaczenie punktów spełniających powyższe kryteria w postaci okręgów na 

warstwie błędów. 
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AK – usunięcie punktów wierzchołkowych spełniających powyższe kryteria. 

18.12 Powtórzone linie/AK 

Kontrola elementów typu LINE pod kątem podwójnych odcinków.  

19 Przeglądanie błędów 

20 Przykłady kontroli i korekty topologii w ewidencji 


